AMP Android SDK: Requirements

Document created by Herberth Alvarado Champion on Aug 11, 2016Last modified by Herberth Alvarado Champion on Apr 9, 2017
Version 10Show Document
  • View in full screen mode

Maintainer: Orlando Sanchez Martinez

This document is part of AMP Android SDK 

 

Pre-requisites

 

The Android AMP SDK complies with the following:

 

  • Android OS
    • Compatible with Android OS 1.6 (Donut) and above
    • Android 4.1 (Jelly Bean) is the minimum required for the newest decoding mode (Exo Mode)
    • Android 4.0 (Ice Cream Sandwich) is the minimum required for AMP's own HLS decoding mode (Hardware Advanced Mode)

 

  • HTTP Live streams (HLS)
    • Supported video codecs
      • H.264
    • Supported audio codecs
      • AAC
    • For maximum compatibility and best performance, Audio/Video encoding must follow Apple’s and Android's recommendations

 

 

This document is part of AMP Android SDK 

Attachments

    Outcomes