TouchTest Device Support

Document created by DPM Admin Employee on Jul 18, 2017Last modified by Trishala Kalal on Aug 10, 2017
Version 2Show Document
  • View in full screen mode

This article contains support information for:

iOS Support

The following table shows which builds correspond with a particular iOS version.

ReleaseiOS Version
57.16iOS 10
56.20iOS 9.3
55.23iOS 9
55.13iOS 8.4.1
55.09iOS 9 beta
54.21iOS 8.4 beta 2
54.18iOS 8.4 beta
54.16iOS 8.3
54.15iOS 8.3 beta 4
54.13iOS 8.3 beta 3, 8.2 beta 2
54.12iOS 8.2
54.08iOS 8.3 beta 2
54.05iOS  8.3 beta
54.04iOS 8.2 beta 5
54.03iOS 8.1.3, 8.1.1
54.01iOS 8.2 beta 4

 

Note: iOS Beta release support is provide on an "as is," "best effort," and an "as available" basis, and some underlying defects are presumed. The primary purpose of iOS Beta version support is to give early access to SOASTA customers building Apps for the next version of iOS, as well as to obtain feedback on performance and the identification of defects. This is provided "as is" because the iOS version is changing as development is continuing until final release.

Supported iOS Devices

The following iOS devices are supported:

  • iPhone 3GS
  • iPhone 4
  • iPhone 4s
  • iPhone 5
  • iPhone 5c
  • iPhone 5s
  • iPhone 6/6+
  • iPod Touch (3rd generation)
  • iPod Touch (4th generation)
  • iPod 5th Gen
  • iPad
  • iPad 2
  • iPad Air
  • iPad Air 2
  • iPad mini
  • iPad Mini 2/3

Device Architecture Support

SOASTA TouchTest™ supports the following device architectures:

  • armv6
  • armv7
  • armv7s
  • arm64

Android Device Support

SOASTA TouchTest™ supports devices running the following Android versions:

  • Nougat (7.0)
  • Marshmallow (6.0)
  • Lollipop (5.0 - 5.1.1)
  • KitKat (4.4-4.4.4)
  • Jelly Bean (4.1-4.3.1)
  • Ice Cream Sandwich (4.0-4.0.4)

Note: For Smart Phones and tablets, Android support includes open source-based custom versions of all Android versions listed above. Custom Android versions on embedded systems, such as those found in car navigation systems, watches, etc., are evaluated for support on a case-by-case basis. Support for these embedded systems is not guaranteed. Android support includes support for Amazon devices.

Gradle Plugin

The plugin number in your build.gradle file must match the release (build) you are using.

ReleaseGradle Plugin Version
57.201.5.1
57.191.5.0
57.181.4.12
57.171.4.12
57.161.4.12
57.151.4.12
57.141.4.12
57.131.4.12
57.121.4.12
57.111.4.12
57.101.4.11
57.091.4.10
57.081.4.10
57.071.4.10
57.061.4.10
57.041.4.10
57.031.4.8
56.241.4.7
56.231.4.7
56.221.4.7
56.211.4.7
56.201.4.7
56.191.4.7
56.181.4.7
56.191.4.7
56.201.4.7
56.211.4.7
56.211.4.7
56.221.4.7

 

CocoaPod Support

The version number in your Podfile must match the CocoaPod version that corresponds with the release (build) you are using.

ReleaseCocoaPod Version
57.201.5.7
57.191.5.7
57.181.5.7
57.171.5.7
57.161.5.6
57.151.5.6
57.141.5.6
57.131.5.6
57.121.5.6
57.111.5.6
57.101.5.6
57.091.5.5
57.081.5.5
57.071.5.4
57.061.5.3
57.041.5.1
57.031.5.1
56.241.5.0
56.231.5.0
56.221.5.0
56.211.5.0
56.201.5.0
56.191.4.8
56.181.4.7

Attachments

    Outcomes