AnsweredAssumed Answered

In API Authorization step my Luna User ID not showing up in the dropdown

Question asked by B-3-1EE2CPX Employee on Jul 28, 2015
Latest reply on Jul 29, 2015 by B-3-1EE2CPX

I have followed the following steps for authorizations, but on the step marked red, I am have issues. I dont see my UserID in the dropdown. What should I do in order to make it available?

 

Authorizations

You can grant a client the authorization to interact with specific APIs in specific ways.

  • Select the desired client in the API Client panel.
  • Click the Authorizations tab.
  • Click the New Authorization button.
    • The New Authorization window appears.
  • Enter a name and, optionally, a description for this authorization.
  • Click the Save and Set API Grants button.
    • The first of the Grant Settings window appears.

You’ll see an alphabetical list of the APIs that are accessible to the selected client. You can also see, if you click the small “+” box to the left of any listed API, the selectable scopes of use for this API (e.g., “READ-ONLY” or “READ-WRITE”). Each scope has a check box to the left of it.

  • Check the desired box(es) to set the authorized scope for each API, authorized for this client.
  • Continue through the list of APIs, dropping down the scopes for each and checking the desired ones.
  • When done setting all the scopes that you want to grant with this authorization, click Next.
    • The second Grant Settings window appears.
  • Enter the Luna Control Center user ID associated with this authorization.
    If there’s a down arrow to the right of this field, you can click it to drop down a full list of user IDs and then select one.
  • When done, click Save.

Outcomes