Vinay Gupta

HLS Ingest Errors on Encoders

Discussion created by Vinay Gupta on Jan 16, 2018
Latest reply on Apr 12, 2018 by EDMBA IT

Hi Community

 

We are currently working on optimising QOS for our current simulcast architecture, We are using Elemental Live 2.10.5 to segment, transcode & then post HLS to Akamai MSL 3.2 configuration. 

 

However since last some time we have started noticing a pattern of Ingest errors on our setup where we can see number of 4xx & 5xx in the Elemental Logs and we were wondering if we are the only one who is noticing such high error rates. We see the errors on posta & postb end points. 

 

Some samples as below. 

 

5xx...

 

2018-01-12 05:58:56 W Setting alert [6006] [75] [6006-75] [OutputAkamai failed to send [16384] bytes for URL [http://post.itv2livenowtv-i.akamaihd.net/219563/itvlive/nowtv/20180111T164045/master_High800/00002/master_High800_01980.ts], HTTP response [503], error [ - ]]
2018-01-12 05:58:56 W Failed to send file to URL [http://post.itv2livenowtv-i.akamaihd.net/219563/itvlive/nowtv/20180111T164045/master_High800/00002/master_High800_01980.ts] after [1] attempts, retrying.

 

 

4xx.... ( Mostly with the creation of a new subdirectory & first segment being posted. )

 

2018-01-11 21:41:03 C OutputAkamai httpChunkDone failed for url [http://post.itv2livenowtv-i.akamaihd.net/219563/itvlive/nowtv/20180111T164045/master_High800/00001/master_High800_00001.ts] response [400] error [ - ].
2018-01-11 21:41:03 W Setting alert [6006] [75] [6006-75] [OutputAkamai httpChunkDone failed for url [http://post.itv2livenowtv-i.akamaihd.net/219563/itvlive/nowtv/20180111T164045/master_High800/00001/master_High800_00001.ts] response [400] error [ - ].]
2018-01-11 21:41:03 C OutputAkamai httpChunkDone failed for url [http://post.itv2livenowtv-i.akamaihd.net/219563/itvlive/nowtv/20180111T164045/master_High800/00001/master_High800_00001.ts] response [400] error [ - ].

 

These ingest errors are at random, at time on posta alone, sometimes on postb and sometimes on both posta & postb. This is causing #EXT-X-DISCONTINUITY-SEQUENCE to be introduced in the HLS mainfest files and  postA and postB going out of sync, causing issues at the player side FastForwards/SkipBacks.

 

If any of you have faced these issues as well ? We have Elemental configured as per Akamai's suggestions but still It's throwing errors on ingest. Any advice - would be great.   

Outcomes