AnsweredAssumed Answered

Token generator not working in the right way

Question asked by Emi Doda on Mar 7, 2018
Latest reply on Mar 13, 2018 by Gunther Kochmann

Hi i have a question regarding the token generator of my iptv streaming website that uses akamai...I have the link of the akamai token generator but the problem is that when i use the HTTP POST in order to take the token from the  url it shows me this (its not a token)

Alt-Svc: hq=":443"; ma=2592000; quic=51303431; quic=51303339; quic=51303338; quic=51303337; quic=51303335,quic=":443"; ma=2592000; v="41,39,38,37,35"

Content-Encoding: gzip

Content-Type: application/json; charset=utf-8

Date: Wed, 07 Mar 2018 16:52:54 GMT

Etag: W/"31-zIZow+wVfq5Z3stS2NUNRdvP0go"

Transfer-Encoding: chunked

Vary: Accept-Encoding

Via: 1.1 google

X-Powered-By: Express

BODYview raw
{"isValid": false,"description": "no token at all"}
I got some strings from the original app and they are shown below :
<-- POST /api/tibo324/getakamaitoken HTTP/1.1 Content-Length: 328 Content-Type: application/x-www-form-urlencoded Host: Connection: Keep-Alive User-Agent: Apache-HttpClient/UNAVAILABLE (java 1.4)  <-- auth=84Kwfr741QQv%252BnUMXtW%252FcbZ6aWNQKN0mCAVccmjo%252FXaf6PaB2pz7j3QqAlxHaj%252Fut%252Bu3vSzDt8NO%250AKqNBIgM7ckBedzNMkGOBRtlFfi3gAUuUzYvFN7U9ClHQKKWtfL%252F%252FyB2o1qyvGc2tY8i8lud%252F3tqg%250AhyjUvUD3Bib11V9aQqx8JOBslArMz%252FUaXLR0skPUETIeQatFmGmhFoyuyPhgbg%253D%253D%250A&AppID=v%252B10zWNKL8RJ8SY6LUSZXg%253D%253D%250A  --> HTTP/1.1 200 OK Server: nginx Date: Tue, 26 Dec 2017 22:24:09 GMT Content-Type: text/html; charset=utf-8 Content-Length: 118 Vary: Accept-Encoding X-Powered-By: Express ETag: W/"76-zi4HHRQAuAUejh/FF9M5ZFJtPek" Via: 1.1 google Alt-Svc: hq=":443"; ma=2592000; quic=51303431; quic=51303339; quic=51303338; quic=51303337; quic=51303335,quic=":443"; ma=2592000; v="41,39,38,37,35"  --> ?__token__=ip=*~hmac=e9afdfe9f6b41c0ca14a16bc60a11253aecd432243789144c1ebaa70f23c615e